rshd(1M)
rshd - remote shell server
As shipped in IRIX 6.5.5. Unchanged since IRIX 6.5.
NAME rshd - remote shell server SYNOPSIS /usr/etc/rshd [-alnL] DESCRIPTION Rshd is the server for the rcmd(3N) routine and, consequently, for the rsh(1C) program. The server provides remote execution facilities with authentication based on privileged port numbers from trusted hosts. The -a option verifies the remote host name and address match on all incoming connections. Normally this check is performed only for connections from hosts in the local domain. The -l option disables validation using .rhosts files. Transport-level keep-alive messages are enabled unless the -n option is present. The use of keep-alive messages allows sessions to be timed out if the client crashes or becomes unreachable. The -L option causes all successful accesses to be logged to syslogd(1M) as auth.info messages. These options should specified in the /etc/inetd.conf file (see inetd(1M)). Rshd listens for service requests at the port indicated in the ``cmd'' service specification; see services(4). When a service request is received the following protocol is initiated: 1) The server checks the client's source port. If the port is not in the range 512-1023, the server aborts the connection. 2) The server reads characters from the socket up to a null (`\0') byte. The resultant string is interpreted as an ASCII number, base 10. 3) If the number received in step 2 is non-zero, it is interpreted as the port number of a secondary stream to be used for the stderr. A second connection is then created to the specified port on the client's machine. The source port of this second connection is in the range 513-1023. 4) The server checks the client's source address and requests the corresponding host name (see gethostbyaddr(3N), hosts(4) and named(1M)). If the hostname cannot be determined, the dot-notation representation of the host address is used. 5) A null terminated user name of at most 16 characters is retrieved on the initial socket. This user name is interpreted as the user identity on the client's machine. 6) A null terminated user name of at most 16 characters is retrieved on the initial socket. This user name is interpreted as a user identity to use on the server's machine. 7) A null terminated command to be passed to a shell is retrieved on the initial socket. The length of the command is limited by the upper bound on the size of the system's argument list. 8) Rshd then validates the user according to the following steps. The local (server-end) user name is looked up in the password file. If the lookup fails, the connection is terminated. Rshd then tries to validate the user using ruserok(3N), which uses the file /etc/hosts.equiv and the .rhosts file found in the user's home directory. If the user is not the super-user, (user id 0), the file /etc/hosts.equiv is consulted for a list of hosts considered ``equivalent''. If the client's host name is present in this file, the authentication is considered successful. If the lookup fails, or the user is the super-user, then the file .rhosts in the home directory of the remote user is checked for the machine name and identity of the user on the client's machine. If this lookup fails, the connection is terminated. The -l option prevents ruserok(3N) from doing any validation based on the user's ``.rhosts'' file, unless the user is the superuser. 9) If the file /etc/nologin exists and the user is not the super-user, the connection is closed. 10) A null byte is returned on the initial socket and the command line is passed to the normal login shell of the user. The shell inherits the network connections established by rshd. SHARE II ACTIONS If the Share II system is installed and enabled, then the following privilege and resource checks are made immediately after validation checks are passed but before the shell is started: 1. If your nologin flag is set, or you already have another connection and your onelogin flag is set, then you are denied connection. 2. If a disk usage exceeds its soft disk limit in any of your domains, then a message is printed and you are given a warning. If you accumulate too many warnings, further connection attempts are denied and you must see your subadministrator to rectify the situation. Whenever you connect with no disk usages in excess of any soft limits, all your accumulated warnings are cleared. 3. If you do not have permission to use an rsh connection, as determined by the terminal permission flag terminal.flag.rsh, then you are denied connection. 4. Some installations place limits on terminal connect-time, which apply equally to connection by way of rsh. If you have already reached your connect-time limit, then you are denied connection. Otherwise, if you have a limit, your remaining connect-time is printed. If all of these checks are passed, rshd proceeds normally. FILES /etc/limconf The compiled Share II configuration file (machine readable). SEE ALSO login(1), rsh(1C), rexecd(1M), rcmd(3N), ruserok(3N), share(5) DIAGNOSTICS Except for the last one listed below, all diagnostic messages are returned on the initial socket, after which any network connections are closed. An error is indicated by a leading byte with a value of 1 (0 is returned in step 10 above upon successful completion of all the steps prior to the execution of the login shell). ``locuser too long'' The name of the user on the client's machine is longer than 16 characters. ``remuser too long'' The name of the user on the remote machine is longer than 16 characters. ``command too long '' The command line passed exceeds the size of the argument list (as configured into the system). ``Login incorrect.'' No password file entry for the user name existed. (Logged to the syslogd(1M) daemon as an auth.notice message.) ``No remote directory.'' The chdir command to the home directory failed. (Logged as an auth.notice message.) ``Permission denied.'' The authentication procedure described above failed. (Logged as an auth.notice message.) ``Connection received using IP options (ignored)'' The remote host tried to use explicit IP source routing. ``Connection from <host> on illegal port'' The remote host used a nonprivileged port. ``Can't find name for <address>'' No hostname was found for the IP address. The authentication procedure described above will use the IP address. ``Host addr <x> not listed for host <y>'' The remote host's name and address did not match. The authentication procedure described above will use the IP address instead of the name. ``Can't make pipe.'' The pipe needed for the stderr, wasn't created. ``Try again.'' A fork by the server failed. ``<shellname>: ...'' The user's login shell could not be started. This message is returned on the connection associated with the stderr, and is not preceded by a flag byte. The Share II specific diagnostic messages are listed as follows: ``Warning <X> of <Y>: soft disk limit exceeded.'' One of your domains has a disk usage in excess of its soft limit. ``Connection denied. Too many warnings.'' You have reached your warning limit. See your subadministrator. ``Connection denied. Already logged in - only one login allowed.'' You are already connected to the system and your onelogin flag is set. ``Connection denied. Currently barred from logging in.'' Your nologin flag is set. ``Connection denied. No permission to use this terminal.'' You are not allowed to log in at this terminal because of a clear terminal.flag.rsh flag. ``You have a remaining terminal connect-time of <Y>.'' You may use this connection until you have used up your remaining connect-time, at which point you are forced to disconnect. ``Connection denied. Terminal connect-time limit exceeded.'' You have already reached your terminal connect-time limit. ``Share not configured - no limit checks.'' The configuration file is unreadable for some reason, so terminal privileges, connect-time limits and disk space limits could not be checked. BUGS The authentication procedure used here assumes the integrity of each client machine and the connecting medium. This is insecure, but is useful in an ``open'' environment. A facility to allow all data exchanges to be encrypted should be present. A more extensible protocol should be used. NOTES rshd will set the LANG environment variable if it is specified in $HOME/.lang.