rexecd(1M)
rexecd - remote execution server
As shipped in IRIX 6.5.5. Unchanged since IRIX 6.5.
NAME rexecd - remote execution server SYNOPSIS /usr/etc/rexecd [ -l ] DESCRIPTION Rexecd is the server for the rexec(3N) routine. The server provides remote execution facilities with authentication based on user names and passwords. NOTE: password aging is not supported by this daemon. Rexecd listens for service requests at the port indicated in the ``exec'' service specification; see services(4). When a service request is received the following protocol is initiated: 1) The server reads characters from the socket up to a null (`\0') byte. The resultant string is interpreted as an ASCII number, base 10. 2) If the number received in step 1 is non-zero, it is interpreted as the port number of a secondary stream to be used for the stderr. A second connection is then created to the specified port on the client's machine. 3) A null-terminated user name of at most 16 characters is retrieved on the initial socket. 4) A null-terminated, unencrypted password of at most 16 characters is retrieved on the initial socket. 5) A null-terminated command to be passed to a shell is retrieved on the initial socket. The length of the command is limited by the upper bound on the size of the system's argument list. 6) Rexecd then validates the user as is done at login time and, if the authentication was successful, changes to the user's home directory, and establishes the user and group protections of the user. If any of these steps fail the connection is aborted with a diagnostic message returned. 7) A null byte is returned on the initial socket and the command line is passed to the normal login shell of the user. The shell inherits the network connections established by rexecd. SHARE II ACTIONS If the Share II system is installed and enabled, then the following privilege and resource checks are made immediately after validation checks are complete (rshd(1)) but before the shell is started: 1. If your nologin flag is set, or you already have another connection and your onelogin flag is set, then you are denied connection. 2. If a disk usage exceeds the soft disk limit in any of your domains, then a message is printed and you are given a warning. If you accumulate too many warnings, further connection attempts are denied and you must see your subadministrator to rectify the situation. Whenever you connect with no disk usages in excess of any soft limits, all your accumulated warnings are cleared. 3. If you do not have permission to use an rexec connection, as determined by the terminal permission flag terminal.flag.rexec, then you are denied connection. 4. Some installations place limits on terminal connect-time, which apply equally to connection by way of rexec. If you have already reached your connect-time limit, then you are denied connection. Otherwise, if you have a limit, your remaining connect-time is printed. If all these checks are passed, rexecd proceeds normally. OPTIONS -l This option causes all successful accesses to be logged to syslogd(1M) as auth.info messages. FILES /etc/limconf The compiled Share II configuration file (machine readable). SEE ALSO login(1), rshd(1M), rexec(3N), passwd(4), share(5) DIAGNOSTICS Except for the last one listed below, all diagnostic messages are returned on the initial socket, after which any network connections are closed. An error is indicated by a leading byte with a value of 1 (0 is returned in step 7 above upon successful completion of all the steps prior to the command execution). ``username too long'' The name is longer than 16 characters. ``password too long'' The password is longer than 16 characters. ``command too long '' The command line passed exceeds the size of the argument list (as configured into the system). ``Login incorrect.'' No password file entry for the user name existed. (Also logged to the syslogd(1M) daemon as an auth.notice message.) ``Password incorrect.'' The wrong was password supplied. (Also logged to the syslogd(1M) daemon as an auth.notice message.) ``No remote directory.'' The chdir command to the home directory failed. ``Try again.'' A fork by the server failed. ``<shellname>: ...'' The user's login shell could not be started. This message is returned on the connection associated with the stderr, and is not preceded by a flag byte. The Share II specific diagnostic messages are listed as follows: ``Warning <X> of <Y>: soft disk limit exceeded.'' One of your domains has a disk usage in excess of its soft limit. ``Connection denied. Too many warnings.'' You have reached your warning limit. See your subadministrator. ``Connection denied. Already logged in - only one login allowed.'' You are already connected to the system and your onelogin flag is set. ``Connection denied. Currently barred from logging in.'' Your nologin flag is set. ``Connection denied. No permission to use this terminal.'' You are not allowed to log in at this terminal because of a clear terminal.flag.rexec flag. ``You have a remaining terminal connect-time of <Y>.'' You may use this connection until you have used up your remaining connect-time, at which point you are forced to disconnect. ``Connection denied. Terminal connect-time limit exceeded.'' You have already reached your terminal connect-time limit. ``Share not configured - no limit checks.'' The configuration file is unreadable for some reason, so terminal privileges, connect-time limits and disk space limits could not be checked. BUGS Indicating ``Login incorrect'' as opposed to ``Password incorrect'' is a security breach which allows people to probe a system for users with null passwords. A facility to allow all data and password exchanges to be encrypted should be present.