ypset(1M)

ypset - point ypbind at a particular NIS server

As shipped in IRIX 6.5. First release of IRIX 6.5.

NAME
     ypset - point ypbind at a particular NIS server

SYNOPSIS
     ypset [ -V1|-V2 ] [ -h host ] [ -d domain ] server

DESCRIPTION
     Ypset tells ypbind(1M) to get the network information service (NIS) for
     the specified domain from the ypserv process running on server.  If
     server is down, or isn't running ypserv, this is not discovered until an
     NIS client process tries to get a binding for the domain.  At this point,
     the binding set by ypset will be tested by ypbind.  If the binding is
     invalid, ypbind will attempt to rebind for the same domain.

     By default, ypbind does not allow ypset operations from local or remote
     hosts.  Ypset will return the error message

          ypset: Sorry, I couldn't send my RPC message to ypbind on host nisserver

     when ypbind rejects the attempt.

     Ypset is useful for binding a client node which is not on a broadcast
     net, or is on a broadcast net which isn't running an NIS server host. It
     also is useful for debugging NIS client applications, for instance where
     an NIS map only exists at a single NIS server host.

     In cases where several hosts on the local net are supplying NIS services,
     it is possible for ypbind to rebind to another host even while you
     attempt to find out if the ypset operation succeeded.  That is, you can
     type "ypset host1", and then "ypwhich", which replies: "host2", which can
     be confusing.  This is a function of the NIS subsystem's attempt to
     load-balance among the available NIS servers, and occurs when host1 does
     not respond to ypbind because it is not running ypserv (or is
     overloaded), and host2, running ypserv, gets the binding.

     Server indicates the NIS server to bind to, and can be specified as a
     name or an IP address.  If specified as a name, ypset will attempt to use
     NIS services to resolve the name to an IP address. This will work only if
     the node has a current valid binding for the domain in question. In most
     cases, server should be specified as an IP address.

     Refer to ypfiles(4) and ypserv(1M) for an overview of NIS.

OPTIONS
     -V1  Bind server for the (old) v.1 NIS protocol.

     -V2  Bind server for the (current) v.2 NIS protocol.

          If no version is supplied, ypset, first attempts to set the domain
          for the (current) v.2 protocol.  If this attempt fails, ypset, then
          attempts to set the domain for the (old) v.1 protocol.
     -h host
          Set ypbind's binding on host, instead of locally. host can be
          specified as a name or as an Internet address.

     -d domain
          Use domain instead of the default domain.

SEE ALSO
     ypwhich(1), ypserv(1M), ypfiles(4)