accessworkstation(1)
accessworkstation - open a remote toolchest or iconview
As shipped in IRIX 6.5.30. Unchanged since IRIX 6.5.
NAME accessworkstation - open a remote toolchest or iconview SYNOPSIS /usr/sbin/accessworkstation [-l login] [-h host] [-f directory] DESCRIPTION The accessworkstation program allows the user to open an IRIX Interactive Desktop directory view or toolchest on a specified machine. It replaces the obsolete newdir(1) program (shipped in previous IRIX releases). Users can run accessworkstation from a Unix shell command line or from the toolchest (Desktop > Access Files > As Another User or By Remote Login). The user is allowed to select interactively the directory or toolchest to be viewed, as well as the machine and login name to be used. The program starts by default with all fields blank. Some fields may be prestocked by specifying command-line arguments: -l login Specifies the user account login to access on the host. -h host Specifies the workstation host to access. -f directory Specifies the directory to be viewed. For example, accessworkstation -l lee -h pacific -f /usr/tmp will run the program with its fields set to log in as user lee on the host pacific and launch a directory view of the /usr/tmp directory. The host pacific may be the local host or a remote workstation accessible through the local network. When run without options, the program will try to minimize required typing by filling in the "Directory to view" field as the user types the login name. It assumes the usual directory to be viewed will be the login user's home directory, and it assumes the usual location for user directories is /usr/people. If user directories are rooted under a different directory, the user can make the accessworkstation program aware of this by editing their $HOME/.Xdefaults file and adding the following line: Accessworkstation*usualHomeBase: <new path> where <new path> should be replaced with the usual path for user directories. For more information about the entire IRIX Interactive Desktop environment, see the IID(1) man page. SEE ALSO remotedir(1), fm(1), xon(1), rsh(1C), xhost(1), IID(1) DIAGNOSTICS Diagnostics generated by accessworkstation are directed to an error dialog specifying that the login request was denied. The following are common diagnostics: "Unable to log in." This signifies that the specified user or the specified password was not typed correctly, or the user with the specified password does not exist on the specified host. "Unable to connect." This signifies that the specified host name was not typed correctly, or that the specified host is not responding and may need to be rebooted. "Permission denied." This signifies that the specified user does not have permission to log in to the specified host without a password. "Login incorrect." This signifies that the specified user does not have an account on the specified host. "/usr/sbin/dirview: not found" This signifies that the specified host does not have the file manager (fm) and/or the IRIX Interactive Desktop installed. "Xlib: Client is not authorized to connect to Server" The specified host is not allowed access to the current DISPLAY. See xhost(1). FILES /usr/lib/X11/app-defaults/Accessworkstation BUGS For a more complete explanation of the following bugs, consult the IRIX Interactive Desktop release notes. The drop pocket for "Directory to view" reflects directories that exist on the local machine, regardless of which host is specified. The iconview will not automatically come up in View As Gallery mode when launched via accessworkstation from a remote Photo CDROM.